Formulas para trabajar en Excel

Muchas formulas más importantes de Excel por más básicas que sean realmente suelen ser muy funcionales para todo lo que hacemos en el trabajo, en esta entrada se presentarán algunas de ellas que te podrán servir sin ningún problema.

Cuando requieres unir textos que se encuentran en diferentes celdas en una sola pueden utilizar la siguiente formula:

=CONCATENAR(A1,A2)

También puedes utilizar con corchetes para unir más texto:

=CONCATENAR(A1,” “,A2,” ¿Cómo están?”)

Cuando requieres realizar un redondear un número

=REDONDEAR(A1,0)

Convertir en mayúsculas de una celda

=MAYUSC(A1)

Convertir en minúsculas del texto de una celda

=MINUSC(A1)

Convertir en mayúsculas del texto de una celda

=MAYUSC(A1)

Suma el valor de los campos que encuentre en una matriz, un ejemplo puede ser el contar solo los numero 3 de una matriz. En la matriz que se muestra el valor de la suma de todos los 3 que se encuentran en la matriz es de 9 para obtener ese resultado se utiliza la siguiente formula:

=SUMAR.SI(A2:A9,C2)

Ahora que pasa si lo que quieres es contar las veces que se encuentra un valor en una matriz, utilizaremos la misma matriz previamente mostrada y haremos el ejercicio, cuantas veces aparecen el numero 1? Son tres veces por lo tanto para realizar este proceso con formula se utiliza la siguiente formula.

=CONTAR.SI(A2:A9,C2)

También se podría hacer la cuenta de celdas que tienen algún valor numero ignorando aquellas que se encuentran vacías y aquellas que cuenten con algún carácter:

=CONTAR(A2:A12)

Asignar un porcentaje a las calificaciones de tareas de los alumnos, ejemplo:

=(B2*C2)+(B3*C3)+(B4*C4)

Si quieres realizar de otra forma la asignación de porcentajes por calificaciones para identificar el 100% también se puede utilizar la siguiente formula:

=SUMAPRODUCTO(B2:B4,C2:C4)

Ahora vamos a utilizar algunas formulas condicionales en Excel, empezaremos con que si el alumno tiene una calificación mayor a 7 saldrá el mensaje de aprobado, de lo contrario reprobado:

=SI(C6>7,”Aprobado”,”Reprobado”)

Ahora usemos un poco más de condicionales, como lo siguiente que pasaría si el alumno tiene un promedio de 6.8 es posible que el profesor promedie a 7 para pasarlo, entonces hay que darle la opción al profesor de escoger con la siguiente formula, sino simplemente reprueba:

=SI(C6>7,”Aprobado”,SI(C6>6.5,”Promedia 7″,”Reprobado”))

Si quieres extraer los valores después de una coma o de alguna cadena de texto especifica de una celda puedes hacer con la formula Extrae de la siguiente manera:

=EXTRAE(A2,ENCONTRAR(“,”,A2)+1,(LARGO(A2)))

Si quieres extraer los valores antes de la coma o de algún otro carácter de una celda, tendría que ser un poco diferente la formula:

=EXTRAE(A2,1,ENCONTRAR(“,”,A2)-1)

Si deseas identificar si se encuentra algún carácter dentro del texto puedes utilizar la siguiente formula para ello:

=NO(ESERROR(HALLAR(“/”,A2,1)))*1

Estas formulas seguro que te pueden funcionar en tu día a día laboral, sobre todo por que son formulas que seguro las vas a necesitar.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *